新手学习适合那个版本

大家好,我刚刚接触PHP半个月,偶然间看见π框架,对π框架非常感兴趣,我想问一下你们,对于小白而言,学习那个版本比较合适呢?
已邀请:

dogstar - PhalApi创始人

赞同来自:

目前:
 
1、关于版本维持
PhalApi 2.x 是全新版本,也是后续会继续维护和更新的版本。而PhalApi 1.x 已经是封存,停止更新了。
 
2、关于主流的composer
PhalApi 2.x 采用了主流的composer,有包管理,也是未来的主要方向。包括Yii 2.x 等各大开源框架也是这样设计和调整的。而 PhalApi 1.x 是基于传统历史的PHP开发的,已经是处于旧版本的做法。
 
3、关于PHP 7
PhalApi 2.x 能更好地支持PHP 7,适合未来的PHP升级。PhalApi 1.x 更多面向 PHP 5。
 
4、关于学习成本
2.x 会比 1.x 稍微多一点学习成本。但如果原来项目不是使用1.x版本,学习上也是很轻松的。
 
综上,推荐初学者直接学习和使用 PhalApi 2.x 版本。

要回复问题请先登录注册